Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

OVERVIEW

In this tutorial you will design a wide beam lens with a peak beam angle around 65° using the Parametric Optical Design
Tools (PODT) and the CREE XP-L LED. The peak intensity value should be at least 8 times the intensity at nadir to ensure
even illumination from the center outward, thus avoiding a hot spot under the lens. This tutorial assumes you know
how run a Photopia analysis inside of SOLIDWORKS. If you need to review the basics of Photopia for SOLIDWORKS, then
start with the Beginner 1: LED TIR Collimator tutorial. http://www.ltioptics.com/en/support-swaddin-
v2015.0.html#pswaitutorials

You will need to have access to the General Refractor Module to complete this tutorial.
Skills Covered:

e Designalens
e Analyze the lens
e Modify the lens to obtain the desired beam shape

Skill Level: Intermediate

o SW PODT Lens.SLDASM: 5/10/2016 11:11:48 PM = =
Photometric Report | Candela Fidi | lluminance Planes | IES File | EULUMDAT Fie | Color Report | Analysis Status |
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

1. Start a New Part
Start SOLIDWORKS and click File > New and choose a Part. Set the units for the part to be MMGS.

Photopia’s PODT module creates reflector and lens profiles in a sketch in a part file. The
profiles are based on several geometric constraints and aiming parameters that you will
define beforehand. 3D features based on these profiles are then created using the
Feature tools within SOLIDWORKS. When you change the underlying PODT profile, the
Features will be updated as well.

2. Start a Sketch and Define Constraints

Select the Top Plane in the Feature Manager Tree, and then choose the Sketch tab from the Command Manager and
click the Sketch button to create a new Sketch.

Next you will create a line which defines the lamp center and beam direction. From the Sketch tab in the Command
Manager, click on the Line button and check “For construction”. Click to start the line at the origin and drag it down
vertically to be about 10mm long. The exact length isn’t critical as this line defines the center of the beam and lens
revolve axis.

Next you will create an arch which defines base profile b B Partl Default<<Defauits.,

of the lens. In this example, the base profile will be the
input surface of the lens.
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

3. Create the Lens
Ensure the sketch still open and click Design lens (Photopia CommandManager Tab) or Tools > Photopia > Design lens.

For the Lamp center property, select the sketch origin. The image below shows references for the Aiming
. Nadir and Aiming Angle Directions for a reflector.
For the Base profile, select the arc. . .
The same aiming angle conventions apply to a lens.
For the 0° aiming direction select the construction line.
Keep the Prism steps & Index of refraction at their defaults (we’ll
assume an acrylic lens).
Set the Minimum thickness to 2.
For the Aiming string enter 0(1)70
. \‘ . . ~
e v @ Partl (Defoult<<Defaults... _A'L\nm?ér_,"g +A:\Eglg oo
Yo BRI E : : B
Create parametric optical refractor (&) Start Point
V¥ X
W
REsgad ~ Aiming Nadir
Reload refractor
New v Counterclockwise = Positive Rotation (+)
Clockwise = Negative Rotation {-)
E Initialization S~
3 Lm"'“l"::m | The Aiming string defines how you want to aim the
5 Base profie ;, light from the lens. The goal of this design is to
g [i[setci-Contour<1- | v create a wide beam angle with a peak intensity at
- P”“‘:;"‘ X 65°. In order to achieve the peak intensity at 65°,
Index of refraction ’ you’ll need to aim light beyond that angle since the
1491 6 beam will continue to taper past the peak. So start
M‘"'m”;th"k““ . ] | with aiming the light 70° from the beam center and
Select an edge ta define the O° aiming ’ e aiming can be adjusted once we see how the
! th be adjusted how th
angle
B | | " lens performs. The Aiming string is entered in the
[ Fip nadir | following format:
Aim by direction W |
Aiming string | Start angle (Angular Increment) Ending angle
ony7o i
I
Target feature ~ | Assuming the bottom of the lens aims light directly
| | | down, the top towards the widest angle, and
- L increments between those two extremes of 1°,
Open the PODT
enter the string:
Advanced v 0(1)70
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Photopia™ for SOLIDWORKSe Tutorial

Click the Open the PODT window button.

Change the Profile type property to Smooth.

4 Aim by angle
Start angle
End angle

Angle Increment

» Aim by point

4 Optical parameters

Optical center X |0.000000

Optical center Y |0.000000

profile type smocth v

Index of refraction  |1.491000 |

Number of aiming |71

% control inside |0.0%

Number of prism |10

Use pull direction | No v

pull direction X 0.000000 |

Pull direction ¥ 0.000000 | i Weight Adj.  Calc Weight  Total Weight % Refractor Aiming Point Y Outer bulge % of control

Draft angle 1.000000 1 1.000000 0.500000 0.500000 0.8% 8y Direction v |0.0° 0.000000 -1000.000000 |0.0° 00° 00%

Esaichiled=de =B 0.000000 2 1.000000 0500152 500152 0% 8y Direction + |1.0° [17452406  |-c00marees 0o [ooe [00%

allcyjitictia RER 0.000000 3 [1.000000 0500810 l0s00s10 Joe% 8y Direction + |200 [s4g00407  |-000300827 oo [ogr [00%

! R T 10 4 [1.000000 [os01372 Joso1372 Jos% 8y Direction + |30° [s2335056  |-o0ms20535 |00 o0 [00%

Outer bulge ang. _|0.0° 5 1.000000 0502422 l050242 Jo8% 8y Direction + |40° leo756a7a  |-0s7.564050 |o0r looe [o0%

L b gReng 00° 6 1.000000 0503820 0503820 0% .Ey Direction + |5.0° 87155743 |-096194688  |00r [ooe [00%

gz nEeliten 1.0 7 1.000000 0505508 l0.505508 los% 8y Direction + |6.0° 104528463 |-soa521895  |00° [ooe [o0%
A @i 2 1.000000 0507310 los07310 los% lBy Direction + |7.0° [121260342  |-vo2sa6132 00" oo [oo%

Offset style Radialfrom lamp_v | g 1.000000 0500828 0500828 Jo8% .Ey Direction + |8.0° [130173101  |-0s0268068  |0.0° looe [o0%

SiiczidEETEs 2000000 | |0 1.000000 0512465 0512465 0% .Ey Direction + |2.0° |156432465  |-o87.688341 |00r looe [o0%

EiESs oy Outside | [ [1.000000 015427 0515827 0% .By Direction + | 10.0° [17368178  |-osasorsa  |oor [ogr [00%

M irgfackn == J 2.000000 [z [1.000000 [os1a717 los1am7 Joa% sy Direction + |11.0° [100808095  |-oa162m183 |0 o0 [o0%
EuiEIghtng 13 [1.000000 0522341 0522341 Joa% |8y Direction + |120° [207011681  |-o78.147601 |o00® oo [00%

it i) on Yl |ha 1.000000 0526304 l0526304 Joa% .Ey Direction + |13.0° |224051058  |-o7a370085 |00r [ooe [00%

RSGaEexprenTI) 1000000 [1s [1.000000 0530614 los30s14 Joe% oy Direction + |14.0° |os1921806  |-o70205726 |0 [ogr [00%

=0t i R 0.500000 16 1.000000 los3s276 los35276 los% 8y Direction + |15.0° |ses10045  |-sesozsezs |00 oo o0

Wweight shift 0.000000 17 [1.000000 0540299 l0540200 o8 8y Direction + |16.0° |a7se37356  |-o61.261696  |o00r [o0® [o0%

Close the PODT window with the red X in the upper right
corner.

Click v on the lens Property Manager to create the lens
profile, which will be displayed in your sketch.

for i
SOLIDWORKS

ltioptics 4



Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

4. Create a Revolved Boss/Base Feature
Ensure the sketch is still open and click the Revolved Boss/Base button (Features CommandManager Tab).

Set the Axis of Revolution to the construction line.

The Contour should have automatically been populated with the PODT profile.

Iiio piics 5 -fS<z;LIDWORKS®
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5. Create an Assembly and Import the LED

Choose File > Save to save the part -
file. Give it a name of SW PODT Efl = B3k

4 @Assemz (Default<Display...

}. Coordinate System [©]
Lens. %
. Selections A
Choose File > Make Assembly N —
from Part to create an assembly Xavis

]
file.

Choose Insert > Reference
Geometry > Coordinate System.
Click in the Z Axis reference box
and then click the Arrow button to
reverse the direction of the z-axis.

Lo [

Click v to create the coordinate
system.

You should see the Z axis of the
reference coordinate system point
in the opposite direction of the
SOLIDWORKS coordinate system in
the lower left corner of the CAD
view.

Y
Z.J
e

Select Coordinate System1 in the FeatureManager and then click the Add
Lamp button (Photopia CommandManager Tab).

Scroll down to the following lamp in the list: XP-L-5700KCORE

You will see Coordinate System1 already referenced to this lamp model,
which will ensure the lamp imports in the correct orientation.

Click v" to import the lamp.
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

6. Prepare & Run the Photometric Simulation

In the Photopia Appearances Tab on the right (green sphere icon), find the “Generic Acrylic 1” refractive material. Use
the filter to show only the Refractive materials so you choose the right one.

Drag this material onto the Len Part in the Feature Manager to assign the material at the component level to the entire
part.

Select Coordinate System 1 in the Feature Manager and then click the Photometric Settings button (Photopia
CommandManager Tab).

Set the Horizontal test angles to: 0.
Set the Vertical test angles to: 0(2.5)90.
Click v save the Photometric Settings.

Click the Start Raytrace button (Photopia CommandManager Tab) to begin the raytrace.

o } Run raytrace E Results Rays
v @ F g s @
Add Add Photometric Raytrace El Results in new window E‘ Illluminance planes Online
Lamp illuminance Settings Settings = Help
plane 29 Results in Photopia Lﬂ Select ray trace geometry
Assembly | Layout | Sketch | Evaluate | SOLIDWORKS Add-Ins | Photopia | 2,
‘
L » (@ 5w PODT Lens (Default<...
@ Bl ¢ &
Photopia photometric output set... @
v X -
Output types A
Report type
mdoor v
Photometry type
Typec vib
Test sphere ~

Horizontal test angles
Vertical test angles

0(2.5)90 v
Select a coordinate system

Coordinate System1

Do not create a mate, just use

[[Ithe current position and
orientation G
Test distance

76096.00mm J

<>

Luminous dimensions N
Compute luminous dimensions
X (90°-270" axis)
0.00mm
Y (0°-180° axis)
0.00mm
7 (depth)
0.00mm

Output scaling A
Scaling

Relative (based on initial lamp It v’

Advanced Vi
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

7. Review the Results

After the raytrace is complete, you should get a candela distribution that looks like the following:
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The results for this initial lens produce a peak below 60° and more light than desired in the center of the beam. Since
we were targeting a 65° peak and a higher ratio between the peak and center beam intensity, we will now adjust the
lens profile.
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

8. Modifying the Lens
Right click on the SW PODT Lens in the Feature Manager and select Edit Part from the flyout menu.

Select the Revolvel feature and then click the Design lens button (Photopia CommandManager Tab).

Under Reload Lens, click the drop down list and choose the
last item in the list. This will associate your initial lens

parameters with the revolved boss/base feature. The Weighting Factors (WF) determine the relative
importance of each lens aiming section. A higher weight

means more of the lens angular extent will be aimed
toward that angle. Increasing the WF exponent generally
creates higher WF’s at wider angles in the beam. A

negative WF exponent creates higher weights in the beam
Set the Weight exponent to 2. This will increase the amount | canter, with a stronger emphasis at 0° the more negative

of light at the high angles.

Weighting Factors

Click the Open PODT window button.

Set the Number of Prism Steps to 100. This will create a
smoother lens profile.

the exponent. See chapter 4 in the Photopia User’s Guide
for a more complete explanation of the WF equation.

The images below show the blue weighting factor plot with the original exponent of 1 and the new value of 2.

The obtained candela plot from the last run is also shown in this view. The higher exponent results in a new lens shape
that gets wider and is dipped in the center as a higher proportion of the lens is aimed toward the wider angles.
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Close this screen

Click the v to update the lens.
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Photopia™ for SOLIDWORKSe Tutorial 3 - PODT Lens Design

9. Rerun the Raytrace

Exit the part edit mode and return to the assembly.

Run the simulation again.

You should now see a beam with the following distribution that has a 65° peak beam angle with a peak intensity over 9
times the value at nadir.
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10. Complete
CONGRATULATIONS! You have completed the PODT lens design tutorial.

Suggested Next Steps:

e Design a new lens with your own beam requirements
e Review the documentation at http://www.ltioptics.com/SWSupport

for i
SOLIDWORKS

Itioptics .


http://www.ltioptics.com/SWSupport

